RouterOS的脚本支持在file下对文件进行操作,例如在file下创建一个yus.txt文件,通过set命名可写入相应的内容

/file print file=yus.txt

/file set yus.txt contents=”123″

 

如果我们需要将当前RouterOS的nat会话数写入文件,做如下操作:

#定义局部变量sessions

:local sessions

#获取当前会话数

:set sessions [/ip firewall connection print count-only ]

#向yus.txt文件写入会话数

/file set [find name=”yus.txt”] contents=”$sessions “

 

通过fetch的ftp模式上传到另外一台RouterOS

/tool fetch address=192.168.10.8 mode=ftp port=2121 user=”admin”  password=”123″ src-path=yus.txt  dst-path=yus.txt upload=yes

 

从另外一台RouterOS中读取文件内容

:local con

:set con [/file get [find name=”yus.txt”] contents ]