RouterOS配置是及时生效,并自动回写到flash中,因此配置完成后,不需要像华为交换机一样,需要手动保存配置。

Backup Save命令:备份配置通常使用backup下的save命令将系统备份为二进制文件,v6提供了对文件加密的选项,备份后存放在File目录下,可使用FTP访问或在winbox中的file列表中下载备份文件,并可以通过load命令恢复备份文件(winbox是restore按钮)。

export导出命令:(类似华为display configuration),导出全局或指定目录下的配置,可指定生成文本文件(后缀为.rsc能用于配置编辑),同样保存在file目录下,能使用FTP或在winbox中的file中下载文件,导入配置可以直接复制到命令行,也可以通过import命令导入文本文件。

reset-configuration系统复位命令将所有的配置信息从RouterOS中全部删除掉,在做此操作前,最好先将路由器的配置备份一次。

系统备份与恢复

操作路径:/system backup

Save指令是保存当前配置到一个备份文件中,显示文件在/file目录中。如果需要恢复指定的备份文件,可通过/system backup中的load指令加载配置,还原当前备份文件的配置。从RouterOS v6.13开始可以对备份文件做加密,增加了don’t-encrypt和password命令

命令描述:

load name=[filename] – 加载备份文件的配置

save name=[filename] – 保存当前的配置到文件中

dont-encrypt – 告诉系统不使用任何加密,并生成可查看的编辑文本(此方式不安全)

password – 当password没有设定,在恢复时要求输入当前管理员的密码,当password被设定,密码输入则替换为当前设置密码。

加密介绍

从RouterOS v6.13的备份文件默认要求使用加密,如果当前RouterOS管理员的管理密码配置,或backup的“password”参数被设置,恢复时要求输入密码。如果当前管理员没有设置管理密码(即admin没有设置密码),这时备份文件将不会被加密。

例如:将当前的配置保存到文件test

[admin@MikroTik] system backup> save name=test
Saving system configuration
Configuration backup saved

[admin@MikroTik] system backup>

在路由器中查看保存的文件:

[admin@MikroTik] > file print
# NAME                           TYPE         SIZE       CREATION-TIME
0 test.backup                    backup       12567      aug/12/2002 21:07:50

[admin@MikroTik] >

导入备份文件test:

[admin@MikroTik] system backup> load name=test
Restore and reboot? [y/N]: y
...

为了保证恢复备份不会失败,请将备份的文件恢复到相同型号的设备和版本,特别RouterOS版本跨度较大的情况下,配置路径和参数可能发生改变!

Winbox下配置直接在files菜单下,通过backup和restore操作,备份要求输入文件名和加密密码

RouterOS云备份

从RouterOS v6.44beta版本开始提供云备份功能,具体细节如下:

  • 免费为MikroTik路由器用户提供
  • 仅支持aes-sha265的备份文件加密
  • 如果你将下载密钥保存,也可以从另外一台路由器下载备份文件
  • 一条命令生成、加密和上传备份文件
  • 一条命令下载和应用备份
  • 连接IP cloud服务器,全程采用加密方式,因此你的备份文件通过安全加密隧道传输
  • 每台路由支持1个云备份文件

如果你只是下载备份文件,仍然需要在/system backup load 里执行文件恢复, 配置云备份基本操作如下:

首先要确保RouterOS能连接网络,并正确配置DNS服务器,通过下面命令生成密钥

[admin@MikroTik] /system backup cloud> print

— retrieving key
— downloading

然后执行云备份操作命令

[admin@MikroTik] /system backup cloud> upload-file action=create-and-upload password=yus
status: finished

查看备份情况:

[admin@MikroTik] /system backup cloud> print
0 name=”cloud-20180927-074829″ size=9.8KiB ros-version=”6.44beta9″ date=sep/27/2018 07:48:31 status=”ok” secret-download-key=”pXNxUwPjU5s3P1ejlhUjoJV”

[admin@MikroTik] /system backup cloud>

注意: 如果The Dude和user-manager 安装在当前系统中,backup工具不会对他们做备份,因此这两个功能备份需要单独操作。

导出指令(Export)

指令名称:export

Export指令用于导出脚本配置,这个命令可以在任何目录下执行。export 同样也可以通过file属性指定保存的.rsc文件名,可用FTP或者进入winbox下载。Export导出的是明文,且是标准的RouterOS配置脚本,所以可以直接进行编辑。

指令描述:

hid-sensitive – 隐藏敏感参数,如密码等信息。

file=[filename] – 保存的文件名。

例如:

[admin@MikroTik] > ip address print
Flags: X - disabled, I - invalid, D - dynamic
#   ADDRESS            NETWORK         BROADCAST       INTERFACE
0   10.1.0.172/24      10.1.0.0        10.1.0.255      bridge1
1   10.5.1.1/24        10.5.1.0        10.5.1.255      ether1

[admin@MikroTik] >

导出一个脚本文件,该文件包含了IP地址配置参数:

[admin@MikroTik] ip address> export file=address
[admin@MikroTik] ip address>

在路由器中查看汇出的文件:

[admin@MikroTik] > file print
# NAME                            TYPE         SIZE       CREATION-TIME
0  address.rsc                     script       315        dec/23/2003 13:21:48

[admin@MikroTik] >

Compact Export

从v5.12新增compact export功能,允许仅导出配置的相关参数,而非所有RouterOS默认配置,例如下面的导出配置:

[admin@MikroTik] > export compact
# jan/02/2012 01:57:23 by RouterOS 5.12
#
/ip pool
add name=dhcp_pool1 ranges=10.1.0.2-10.1.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether3 name=dhcp1
/ip address
add address=10.1.0.1/24 interface=ether3
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=10.1.0.0/24 gateway=10.1.0.1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=10.5.8.1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/ip smb shares
set [ find default=yes ] directory=/pub
/system ntp client
set primary-ntp=10.1.1.1 secondary-ntp=10.1.1.2
/system routerboard settings
set cpu-frequency=266MHz
/tool bandwidth-server
set authenticate=no
[admin@MikroTik] >

注意:从v6rc1版本后 ”export compact”被默认执行,如果要使用旧的导出格式,使用export verbose

/export verbose file=myConfig

Compact export作为紧凑导出配置,省略了RouterOS默认配置,这种默认配置是无法被删除,通过”*”表示,如下面OSPF事例中默认配置

[admin@SXT-ST] /routing ospf instance> print
Flags: X - disabled, * - default
0  * name="default" router-id=0.0.0.0 distribute-default=never
redistribute-connected=as-type-1 redistribute-static=no
redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no
metric-default=1 metric-connected=20 metric-static=20 metric-rip=20
metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in
out-filter=ospf-out

Winbox的file目录下,可以查看生成的.rsc的文件:

导入指令(Improt)

操作路径:/import

import命令只能在根目录下使用/import “filename”指令导入指定配置。这种方式适用于部分配置或者功能。

指令描述:

file=[filename] – 导入的路由器配置文件

例如使用下面的指令操作导入配置文件:

[admin@MikroTik] > import address.rsc
Opening script file address.rsc
Script file loaded successfully

[admin@MikroTik] >

系统复位

操作路径:/system> reset-configuration

这个指令将会清除掉路由器的所有配置,包括登陆的账号和密码(恢复为“admin“和空密码),在reset指令执行后路由器将会重启。复位后RouterOS会使用出厂默认配置,可以通过命令查看默认配置(/system default-configuration print)。对于MikroTik硬件设备,复位后会使用默认配置,不同型号MikroTik的出厂默认配置可以参考:各种MikroTik设备的初始化默认配置介绍

在命令行服务器配置,例如:

[admin@Office] /system> reset-configuration
Dangerous! Reset anyway? [y/N]: y

复位时你在命令后也可以带相关参数,如下:

[admin@MikroTik] /system> reset-configuration
keep-users  no-defaults  run-after-reset  skip-backup

复位时可带keep-users指令,描述如下:

Keep-users – 复位不删除管理用户账号

no-defaults – 不加载任何默认配置,清空所有

skip-backup – 当yes被指定自动备份将不会再复位前创建

run-after-reset – 在run after reset指定后export档后,复位会导入指定的RouterOS脚本配置文件。

注意:如果MikroTik RB、CRS和CCR硬件设备使用netinstall安装,并且指定了一个初始的脚本配置写入ROM中,则reset复位命令执行在清除配置,实际是载入的该脚本。要阻止这样的情况,必须重新使用netinstall安装路由器,配置文件指定为空。

打赏

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦

文章很值,打赏犒劳作者一下