IPv6业务地址运营商通过三层互联,将前缀64的地址指定到用户的RouterOS,RouterOS通过无状态地址自动配置方式将业务IPv6地址分配给终端使用者,如事例中的一台CentOS 7服务器。

三层互联地址运营商:2001:d9:e800:101::1/127,本地:2001:d9:e800:101::/127

业务地址2001:d9:e800:102::/64

首先,进入winbox的ipv6下address菜单,添加IPv6地址

互联地址配置到ether1接口,业务IP地址配置到ether2接口

配置脚本:

 

/ipv6 address

add address=2001:d9:e800:101::/127 advertise=no interface=ether1

add address=2001:d9:e800:102::1 interface=ether2 advertise=yes

 

注意在ether2接口上配置advertise=yes,通过启用宣告功能,开启无状态自动配置

然后进入ipv6 – route添加默认路由

配置脚本

 

/ipv6 route

add distance=1 gateway=2001:d9:e800:101::1

 

接下来配置配置CentOS 7服务器,首先查看网卡配置,默认情况下,CentOS 7已经默认设置了IPv6的相关参数

[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-ens160

TYPE=Ethernet

PROXY_METHOD=none

BROWSER_ONLY=no

BOOTPROTO=static

DEFROUTE=yes

IPV4_FAILURE_FATAL=no

IPV6INIT=yes

IPV6_AUTOCONF=yes

IPV6_DEFROUTE=yes

IPV6_FAILURE_FATAL=no

IPV6_ADDR_GEN_MODE=stable-privacy

NAME=ens160

UUID=ef040552-9e68-4a4a-9be3-fd9bfbe93c7d

DEVICE=ens160

ONBOOT=yes

IPADDR=192.168.20.2

NETMASK=255.255.255.0

GATEWAY=192.168.20.1

 

现在通过命令ip -6 addr查看获取的IPv6地址

[root@localhost ~]# ip -6 addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000

    inet6 ::1/128 scope host

       valid_lft forever preferred_lft forever

2: ens160: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000

    inet6 2001:d9:e800:102:beb8:3427:cbb7:2ba/64 scope global noprefixroute dynamic

       valid_lft 2591763sec preferred_lft 604563sec

    inet6 fe80::2c1d:2fbb:990e:3845/64 scope link noprefixroute

       valid_lft forever preferred_lft forever

 

可以看到ens160网卡,已经获取的IPv6地址

 

由于ND下默认配置,DNS宣告是关闭的,因此我们要进入ND菜单下,将Advertise DNS开启,下发DNS给CentOS 7

 

通过ND宣告DNS,在宣告前我们要在RouterOS配置IPv6网络的DNS ,ip dns菜单下支持v4和v6的DNS

[admin@MikroTik] > ip dns set server=2001:d9:e800:101::

 

由于ND下默认配置,DNS宣告是关闭的,因此我们要进入ND菜单下,将Advertise DNS开启,下发DNS给CentOS 7

在CentOS 7服务器上,重启网络服务

[root@localhost ~]# service network restart

 

查看CenTOS 7的解析配置文件,获取了IPv6的DNS

[root@localhost ~]# cat /etc/resolv.conf

# Generated by NetworkManager

nameserver 2001:d9:e800:101::