RouterOS策略路由是维护两个或两个以上的路由表,因此创建源地址策略路由也是要新建路由表,在RouterOS里配置源地址策略路由方法有两种:

  • 基于ip route rule直接配置源地址策略,配置简单,可选参数少
  • 基于ip firewall mangle标记路由策略,有更多的参数可以选择,配置更加灵活

两种方法都会新建一张路由表,操作方法各有不同,通过下面的简单事例讲解下:

根据上图的一个双线网络结构,配置主机192.168.88.9走线路2,其余主机走线路1

接口情况如下:

Ether1:10.10.0.2/24

Ether2:20.20.0.2/24

Ether3:192.168.88.1/24

首先配置ip地址

[admin@MikroTik] >/ip address

[admin@MikroTik] /ip address> add address=10.10.0.2/24 interface=ether1

[admin@MikroTik] /ip address> add address=20.20.0.2/24 interface=ether2

[admin@MikroTik] /ip address> add address=192.168.88.1/24 interface=ether3

添加默认路由,使用10.10.0.1作为路由的默认网关

[admin@MikroTik] /ip address> /ip route

[admin@MikroTik] /ip route>add gateway=10.10.0.1

添加nat规则

[admin@MikroTik] /ip route > /ip firewall nat

[admin@MikroTik] /ip firewall nat > add chain=srcnat action=masquerade

方法一:

配置192.168.88.9源地址策略路由,首先选择ip route rule的方法配置

进入ip route rule,新建一个规则,并设置src-address=192.168.88.9,table=src_rule

这里新建一个src_rule路由表,将源地址为192.168.88.9放入进行路由查询

进入ip route,添加规则,选择routing-mark=src_rule,即src_rule表的网关20.20.0.1

主机192.168.88.9的源地址策略路由配置完成。

在ip route 右上角的下拉菜单,可以选择添加的src_rule路由表,以及main主路由表

方法二:

接下来看看mangle标记的方法,进入ip firewall mangle标记源地址192.168.88.9的策略,选择链表prerouting

进入ip route为src_mangel路由表添加网关

以上两种方式实现的结果都是一样的,但可以看到mangle添加路由标记时,可选择参数明显比rule多很多。