随着多核心CPU和超线程的发展,当前RouterOS v6后simple queue是基于多CPU负载均衡,即每条simple queue负载到一个CPU。因此在配置simple queue时,需要注意配置规则与多CPU负载问题,下面实例告诉你配置simple queue的注意事项

假设我们硬件是多CPU,下面的配置基于v6.34.3,这个simple queue配置将192.168.88.2和192.168.88.3主机写入一条simple queue规则,这样被识别为一条线程,被分配到一个CPU处理。

/queue simple

add max-limit=100M/100M name=queue1 target=192.168.88.2/32,192.168.88.3/32

下面将两个主机分别写成两条规则的流控,修改后,可以同时负载到两个CPU处理,当然你可以根据自己需要调整规则保障CPU负载均衡

/queue simple

add max-limit=50M/50M name=queue1 target=192.168.88.2/32

add max-limit=50M/50M name=queue2 target=192.168.88.3/32