MikroTik RouterOS支持即插即用(Universal Plug and Play),通用即插即用 (UPnP) 是一种用于 PC 计算机、智能设备和其他网络设备的常见对等网络连接的体系结构,即建立透明的点对点网络连接。

 

参考下面的一个简单的网络,外网接口是ether1(IP地址10.0.0.112/24),内网接口是ether2(IP地址192.168.0.0/24)

 

在正确配置网络后,确定src-nat伪装策略已经配置:

[admin@MikroTik] ip upnp> /ip firewall src-nat print

Flags: X – disabled, I – invalid, D – dynamic

  0   chain=srcnat action=masquerade out-interface=ether1

[admin@MikroTik] ip upnp>

 

进入ip upnp 启用UPnP服务:

[admin@MikroTik] ip upnp> set enable=yes

[admin@MikroTik] ip upnp> print

                             enabled: yes

    allow-disable-external-interface: yes

                     show-dummy-rule: yes

[admin@MikroTik] ip upnp>

 

winbox操作路径:

 

配置相应的接口,设置外部接口和内部接口,ether1为外部接口,ether2为内部接口

[admin@MikroTik] ip upnp interfaces> add interface=ether1 type=external

[admin@MikroTik] ip upnp interfaces> add interface=ether2 type=internal

[admin@MikroTik] ip upnp interfaces> print

Flags: X – disabled

  #   INTERFACE TYPE

  0 X ether1    external

  1 X ether2    internal

 

[admin@MikroTik] ip upnp interfaces> enable 0,1

[admin@MikroTik] ip upnp interfaces>

 

Winbox操作,如果你是ADSL或光猫的pppoe-out1拨号接口,就选择external外部interface为pppoe-out1