6.41调整了bridge菜单,并新增了IGMP Snooping功能,因此做了基于hAP ac的IGMP测试,IGMP Snooping仅只有少数几款CRS产品支持hw-offloading,因此RB设备基本都不支持hw-offloading,全部需要CPU来处理,包括hAP ac。

 

这里测试的组播信号通过VLAN传递,上级设备是华为s5700,通过千兆以太网接口与hAP ac连接,组播信号配置在vlan 3000

 

hAP ac配置如下

 

/interface bridge

add name=bridge1 vlan-filtering=yes

 

/interface bridge port

add bridge=bridge1 disabled=no interface=ether2 pvid=3000

add bridge=bridge1 disabled=no interface=ether3 pvid=3000

add bridge=bridge1 disabled=no interface=ether1 pvid=3000

 

/interface bridge vlan

add bridge=bridge1 tagged=bridge1 untagged=ether1,ether2,ether3 vlan-ids=3000

 

配置完成后,进行实际的流量测试,这里特别说明下,由于组播信号配置问题,在一个组播IP配置了多个不同端口的频道,导致获取一个组播视频流时,会接收到其他频道的信号,因此流量达到237Mbps。

Ether2为接收s5700的组播信号,ether1为windows测试组播视频电脑,而ether3是为配合测试组播信号广播添加的

 

测试环境1:关闭IGMP Snooping

/interface bridge

Set bridge1 igmp-snooping=no

 

下面是测试截图

 

 

这个测试可以看到没有开启IGMP Snooping下,ether1接到windows电脑播放组播视频,ether3同样会发送组播信号,说明没有实现IGMP Snooping功能,同时CPU达到74%。

 

测试环境2:打开IGMP Snooping

 

/interface bridge

Set bridge1 igmp-snooping=yes

 

下面是测试截图

 

这个测试开启IGMP Snooping后,组播数据只发到了ether1接到windows电脑播放组播视频,而ether3没有出现组播数据。说明IGMP Snooping功能实现,同时CPU降低到27%。

 

 

WLAN无线组播问题

 

基于RouterOS系统在做无线网桥传输时,会涉及到组播问题,普通配置是无法正常传输到另外一端的,需要在ap-bridge端单独开启multicast-helper=full(v5.15后支持),station端的设备需要配置为station-bridge模式

 

multicast-helper=full打开后,组播能正常传输,但要注意组播是多播方式,因此在传输组播信号时,会向局域网内所有端口进行广播数据,因此支持组播协议,很多设备需要支持IGMP Snooping,RouterOS也不例外,而桥接支持IGMP Snooping只有在RouterOS v6.41版本支持,因此需要升级到该版本,并打开bridge的IGMP Snooping功能,以此避免广播发生,节约系统资源开销。

 

下面测试是在一台hAP ac和hAP lite之间做的测试,只是为了验证IGMP Snooping在无线桥接开启和关闭的情况对比

 

hAP ac使用wlan1的2.4G网卡,无线配置:

/interface wireless

set wlan1 band=2ghz-g/n channel-width=20/40mhz-eC frequency=auto mode=ap-bridge multicast-helper=full \

ssid=MikroTik wds-default-bridge=bridge2 wds-mode=dynamic-mesh wireless-protocol=nv2

hAP lite配置wlan1,无线配置:

/interface wireless

set wlan1 band=2ghz-g/n channel-width=20/40mhz-eC frequency=auto mode=station-bridge \

ssid=MikroTik wds-default-bridge=bridge2 wds-mode=dynamic-mesh wireless-protocol=nv2

 

下面是hAP lite的bridge1未启用IGMP Snooping,CPU为68%

 

下面hAP lite在开启IGMP Snooping后的情况,CPU使用率为51%