hAP ac lite、hAP ac和hAP ac2三款基于802.11ac的无线路由器,支持2.4G和5G双频,也就是802.11bgn和802.11ac两个协议同时工作。由于802.11ac采用5G频率覆盖范围有限,一般仅能在视距内传输,但能提供更高的带宽,如果3×3 80MHz的MIMO可以获得1.3G的带宽,如果非视距内只能通过802.11bgn来弥补。下面是关于802.11n和802.11ac的技术参数,以及hAP ac和hAP ac lite在无线MIMO的区别

 

技术规格 802.11n@40MHz 802.11ac@80MHz
hAP ac  3×3 支持 450Mbps 3×3 支持1.3Gbps
hAP ac lite  2×2 支持300Mbps 1×1 支持433Mbps
hAP ac2 2×2 支持300Mbps 2×2 支持866Mbps

 

不过作为客户端同时只能连接一个频率,要么2.4G的802.11bgn,要么5G的802.11ac,一般802.11ac的路由器会提供2.4G和5G两个配置,即两个无线网络一个2.4G或一个5G,配置不同两个不同的SSID。也可以配置所谓的双频合一,即使采用双频合一相同的SSID,客户端也只会连接到一个频率上,只是会在两个频率上根据信号强弱做切换。很多厂商的无线路由器提供了双频合一的设置,这样的设置客户端也只是在5G信号好的时候连接802.11ac,当5G信号变弱后,切换到2.4G的802.11bgn。

 

RouterOS如何设置双频合一

以hAP ac为例,路由器里可以看到两个无线网卡,一个wlan1是802.11bgn,一个wlan2是802.11ac

 

两张无线网卡负责不同的协议,那该如何设置双频合一,AR9300负责802.11bgn,AR9888负责802.11ac,我的思路是把两个无线网卡做WDS漫游方式,即两个网卡SSID相同,无线网卡mode=ap-bridge,通过桥接创建rstp协议的WDS无线漫游。配置如下

1、桥接配置

进入bridge创建bridge1

/interface bridge
add name=bridge1 protocol-mode=rstp

 

进入bridge port将wlan1和wlan2加入bridge1

 

/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2

2、网络配置

配置路由器bridge1的IP地址,即分给用户的IP地址段

 

/ip address
add address=192.168.88.1/24 interface=bridge1

创建DHCP服务,配置地址池:

/ip pool
add name=pool1 ranges=192.168.88.2-192.168.88.100

配置DHCP服务的接口和地址池
/ip dhcp-server
add address-pool=pool1 disabled=no interface=bridge1 name=server1

配置DHCP服务分配给用户的网关和DNS服务器

/ip dhcp-server network
add dns-server=192.168.88.1 gateway=192.168.88.1 netmask=24

配置DNS服务器IP地址和开启DNS本地解析

/ip dns
set servers=61.139.2.69 allow-remote-requests=yes

启用nat转换

/ip firewall nat
add action=masquerade chain=srcnat

3、无线网络配置

配置无线安全密码,创建wpa/wpa2的无线密码,设置为1234567890

/interface wireless security-profiles
add mode=dynamic-keys authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm name=yus unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=1234567890 wpa2-pre-shared-key=1234567890

配置无线网卡,设置两个无线网卡SSID相同取名yus,设置wds模式为dynamic-mesh,wed-default-bridge为bridge1

/interface wireless
set [find default-name=wlan1] ssid=yus band=2ghz-b/g/n disabled=no frequency=2422 mode=ap-bridge security-profile=yus wds-default-bridge=bridge1 wds-mode=dynamic-mesh

set [find default-name=wlan2] ssid=yus band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no frequency=5745 mode=ap-bridge security-profile=yus wds-default-bridge=bridge1 wds-mode=dynamic-mesh

以上配置完成后,终端设备会自动连接信号最强的频率,例如首先当连接上5G的802.11ac,当你移动5G信号变弱后,终端设备会自动连接到2.4G的802.11bgn,但如果你要从802.11bgn切换到802.11ac,需要你终端设备去完成,而非路由器决定。无线漫游的切换都是由终端设备决定的。