MikroTik硬件设备都有reset按钮,部分设备还带有一个Mode按钮,他们作用如下:

Reset按钮:除了能在路由器启动时复位、设置CAP和启动网络安装RouterOS外,还能在路由器运行时定义执行脚本。(关于RB、CCR和CRS复位键的功能说明

Mode按钮:在部分RouterBOARD设备支持,此按钮提供了对RouterOS的脚本支持,也就是当按下mode按钮,RouterOS会执行指定的脚本。

当前支持mode按钮的设备列表:

RBcAP-2nD (cAP)
RBcAPGi-5acD2nD (cAP ac)
RBwsAP5Hac2nD (wsAP ac lite)
RB750Gr3 (hEX)
RB760iGS (hEX S)
RB912R-2nD (LtAP mini, LtAP mini LTE/4G kit)
RBD52G-5HacD2HnD (hAP ac^2)
RBLHGR (LHG LTE/4G kit)
RBSXTR (SXT LTE/4G kit)
CRS328-4C-20S-4S+RM
CRS328-24P-4S+RM
CCR1016-12G r2
CCR1016-12S-1S+ r2
CCR1036-12G-4S r2
CCR1036-8G-2S+ r2
RBD53G-5HacD2HnD (Chateau)
RBD53GR-5HacD2HnD (hAP ac^3)

 

hAP ac3的Reset和Mode按钮

Mode按钮实例:

按下Mode按钮后,执行一个info日志信息脚本,在log下显示mode button is pressed

/system script add name=test-script source={:log info message=("mode button pressed ");}
/system routerboard mode-button set on-event=test-script enabled=yes

 

修改mode按钮的hold-time时间为3~5秒,即按压mode按钮,到3秒开始到第5秒结束的时间范围执行脚本,配置如下:

/system script add name=test-script2 source={:log info message=("test2");}
/system routerboard mode-button set on-event=test-script2 hold-time=3..5 enabled=yes

 

Reset按钮工作方式也相同,在 /system routerboard reset-button定义,实例如下:

/system script add name=test-reset-button source={:log info message=("reset button pressed");}
/system routerboard mode-button set on-event=test-reset-button hold-time=0..10 enabled=yes

 
注意:从RouterOS 6.47 reset按钮也支持hold-time参数,用于修改按钮时间间隔范围,reset按钮执行脚本只能是在路由器已经启动完成下操作。

Reset和Mode两个按钮,提供了外部按钮执行脚本的功能,给管理员提供了更多可操作的空间,例如按下mode,可以执行某些命令清除操作,启用某些硬件。也可以用reset按钮作为某个功能的开,mode按钮作为功能的关。这些操作就看不同网络环境的实际需求,完全是人的自由发挥。