L3 hw-offloading的三层路由转发下发到交换芯片处理的配置,必须是将网络接口加入同一个bridge,在同一交换分组下,将IP配置在VLAN接口,不能直接把IP配置到接口,相当于华为交换机在interface vlan下配置IP地址,注意这个是非nat路由转发,实例配置拓扑如下:

配置时,首先确保接入端口都加入到bridge,并设置vlan-filter=yes

/interface bridge

add admin-mac=48:8F:5A:4D:00:01 auto-mac=no name=bridge vlan-filtering=yes

进入bridge port菜单,将sfpplus1和ether1加入bridge,并分别配置接口的pvid为200和500

/interface bridge port

add bridge=bridge interface=sfp-sfpplus1 pvid=200

add bridge=bridge interface=ether1 pvid=500

在bridge vlan菜单下,将vlan200和vlan500,tagged给bridge,交给CPU处理,建立interface vlan的三层接口

/interface bridge vlan

add bridge=bridge tagged=bridge vlan-ids=200

add bridge=bridge tagged=bridge vlan-ids=500

在interface vlan下,创建vlan200和vlan500的接口

/interface vlan

add interface=bridge name=vlan200 vlan-id=200

add interface=bridge name=vlan500 vlan-id=500

在ip address菜单下,添加IP地址

/ip address

add address=192.168.1.1/24 interface=vlan500

add address=192.168.88.2/24 interface=vlan200

在ip route菜单创建默认路由

/ip route

add dst-address=0.0.0.0/0 gateway=192.168.88.1

设置L3hw为yes,开启三层路由硬件转发

/interface ethernet switch

set 0 l3hw=yes

设置生效后,测试迅雷下载,流量在物理接口可以看到,但VLAN接口并未显示有流量,CPU占用仅1%,说明L3 HW的设置已经生效,如下图:

支持L3 HW的设备,请参考http://www.irouteros.com/?p=1094